User Tools

Site Tools


k2:k2.1:start

2.1 Installation from the package sources of the used Linux distribution (Ubuntu)

At present, it is not advisable to use the installation from the package sources of the Ubuntu versions used up to 14.10 at this time:

  • Under Ubuntu 12.04 only Gambas2 is offered.
  • The Gambas versions for Ubuntu 12.10 - 14.04 are obviously faulty.
  • Under Ubuntu 14.10 you will only find the older Gambas version 3.5.4.

If, for whatever reason, you decide to install Gambas version 3.5.4 from the package sources under Ubuntu 14.10, you will find installation instructions here. There are two alternative ways to install it:

Variant 1 –> Ubuntu Software Center

You first search for' gambas' in the search mask. Then you will be offered Gambas 3.5.4. You can first view more information or install Gambas 3.5.4.

Variant 2 –> Synaptic package management

In the synaptic package management,' gambas' is entered in the quick selection filter and searched for' gambas' using the' Search' button. Then all relevant Gambas packages are selected and marked for installation. Please also scroll down, because some packages are shown in the list below. With' Apply' the installation of gambas is started.

Advantages:

  • In this procedure with one of the two variants, gambas are installed in the simplest way, because the package dependencies are resolved.
  • Both variants are tried and tested and safe for beginners.
  • Under' Applications> Development> Gambas' you can find the program Gambas and can start the development environment (IDE) from there.

Disadvantages:

  • You will only get the gambas version that has been given to the used Ubuntu version!
  • An update is only possible if the sources for the used Ubuntu version have been renewed. You can't rely on that - unfortunately.

Conclusion:

  • Installs the gambas version of the Ubuntu distribution with all required libraries and dependencies.
  • The uninstalling of the installed Gambas version is just as safe via the Ubuntu software center as it is via the synaptic package management.

Download

2.1 Installation aus den Paket-Quellen der verwendeten Linux-Distribution (Ubuntu)

Gegenwärtig muss von der Verwendung der Installation aus den Paket-Quellen der verwendeten Ubuntu-Versionen bis 14.10 abgeraten werden:

  • Unter Ubuntu 12.04 wird nur Gambas2 angeboten.
  • Die Gambas-Versionen für Ubuntu 12.10 – 14.04 sind offensichtlich fehlerhaft.
  • Unter Ubuntu 14.10 finden Sie nur die ältere Gambas-Version 3.5.4.


Sollten Sie sich – aus welchen Gründen auch immer – für die Installation der Gambas-Version 3.5.4 aus den Paket-Quellen unter Ubuntu 14.10 entscheiden, dann finden Sie hier eine Installationsanleitung. Für die Installation gibt es zwei alternative Wege:

Variante 1 → Ubuntu-Software-Center

Sie suchen zuerst in der Such-Maske nach 'gambas'. Dann wird Ihnen Gambas 3.5.4 angeboten. Sie können sich zuerst weitere Informationen ansehen oder gleich Gambas 3.5.4 installieren.

Variante 2 – Synaptik-Paketverwaltung

In der Synaptik-Paketverwaltung wird im Schnellauswahl-Filter 'gambas' eingetragen und über den 'Suchen-Button' nach 'gambas' gesucht. Dann werden alle relevanten Gambas-Pakete ausgewählt und zum Installieren vorgemerkt. Bitte auch nach unten scrollen, weil einige Pakete weiter unten in der Liste angezeigt werden. Mit 'Anwenden' wird die Installation von Gambas angeschoben.

Vorteile:

  • Bei dieser Vorgehensweise mit einer der beiden Varianten wird Gambas auf die einfachste Art installiert, weil die Paketabhängigkeiten aufgelöst werden.
  • Beide Varianten sind erprobt und auch für Einsteiger sicher.
  • Unter 'Anwendungen> Entwicklung> Gambas' findet man das Programm Gambas und kann von dort die Entwicklungsumgebung (IDE) sofort starten.

Nachteile:

  • Man erhält immer nur die Gambas-Version, die der verwendeten Ubuntu-Version mitgegeben worden ist!
  • Ein Update ist nur möglich, wenn die Quellen für die verwendete Ubuntu-Version erneuert worden sind. Darauf können Sie sich nicht verlassen – leider.

Fazit:

  • Es wird die zur verwendeten Ubuntu-Distribution gehörende Gambas-Version mit allen erforderlichen Bibliotheken und Abhängigkeiten installiert.
  • Auch das De-Installieren der installierten Gambas-Version gelingt über das Ubuntu-Software-Center genauso sicher wie über die Synaptik-Paketverwaltung.

Download

The website uses a temporary session cookie. This technically necessary cookie is deleted when the browser is closed. You can find information on cookies in our privacy policy.
k2/k2.1/start.txt · Last modified: 02.07.2018 (external edit)

Page Tools